Task 1  :  Configure Topology as given pic.
Task 2 :   Configure IP address As according given.
Task 3 :   Create Loopback as given pic
Task 4 :   Check  Connection PC to 8..8.8.8 loopback ( make sure witch path they select by default )
Task 5 :   HSRP Enable and make Active and standby Router.
Task 6 :   Make Successfully connection PC to 8.8.8.8
-----------------------------------------------------------------------------------------------------------

 Task 1  :  Configure Topology as given pic.


-----------------------------------------------------------------------------------------------------------

Task 2 :   Configure IP address As according given.

R1 ( Cloud )

R1(config)#
R1(config)#interface serial 1/0
R1(config-if)#
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#

R1(config)#interface serial 1/1
R1(config-if)#
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#


R2

R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#

R2(config)#interface serial 1/0
R2(config-if)#
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit


R2(config)#interface fastEthernet 0/0
R2(config-if)#
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
 


R3

R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#

R3(config)#interface serial 1/1
R3(config-if)#
R3(config-if)#ip address 192.168.13.3 255.255.255.0
R3(config-if)#
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#
R3(config)#interface fastEthernet 0/0
R3(config-if)#
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#


R4 (PC)


R4#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#
R4(config)#no ip routing
R4(config)#ip default-gateway 192.168.1.2             
R4(config)#  
R4(config)#interface fastEthernet 0/0
R4(config-if)#
R4(config-if)#ip address 192.168.1.1 255.255.255.0
R4(config-if)#
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#


-------------------------------------------------------------------------------------------------------

Here We can See default gateway one time only one router can set R2 OR R3 But in the condition or redundancy WE have to enable HSRP.

------------------------------------------------------------------------------------------------------

 
 Task 3 :   Create Loopback as given pic

R1(config)#
R1(config)#interface loopback 0
R1(config-if)#
R1(config-if)#ip address 8.8.8.8 255.255.255.0
R1(config-if)#exit
R1(config)#


------------------------------------------------------------------------------------------------------

Task 4 :   Check  Connection PC to 8..8.8.8 loopback ( make sure witch path they select by default )

After enable ( EIGRP AS 1 ) 

pc#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/75/96 ms
pc#


traceroute

pc#traceroute 8.8.8.8

Type escape sequence to abort.
Tracing the route to 8.8.8.8

  1 192.168.1.2 68 msec 76 msec 20 msec
  2 192.168.12.1 72 msec 96 msec 56 msec
pc#

 

here we can see packet are going from 192.168.12.1 because we set as default gateway but in case of down the R2 so all network will get down.

here is solution.

-------------------------------------------------------------------------------------------------------------

Task 5 :   HSRP Enable and make Active and standby Router  

HSRP Always enable on edge (isp end ) Router here is R2,R3 is ISP end ( edge ) Router.

let's look.

R2

R2(config)#int fa 0/0
R2(config-if)#standby 1 ip 192.168.1.254
R2(config-if)#

R2(config-if)#standby 1 priority 200
R2(config-if)#
R2(config-if)#standby 1 preempt
R2(config-if)#exit


R3

R3(config)#interface fastEthernet 0/0
R3(config-if)#
R3(config-if)#standby 1 ip 192.168.1.254
R3(config-if)#

R3(config-if)#standby 1 priority 150
R3(config-if)#

R3(config-if)#standby 1 preempt
R3(config-if)#
 

Check Status of R2

R2#show standby brief
                     P indicates configured to preempt.
                    
Interface   Grp    Pri     P         State          Active              Standby                   Virtual IP
Fa0/0        1       200     P        Active         local                192.168.1.3                 192.168.1.254
R2#
R2#
 


Here Active is Local ( R2) Standby is 192.168.1.3 ( R3) if R2 down R3 will automatically active.


R3
 
R3#show standby brief
                     P indicates configured to preempt.
                     |
Interface    Grp     Pri     P    State        Active          Standby         Virtual IP
Fa0/0         1        150    P   Standby   192.168.1.2     local           192.168.1.254
R3#
 


-------------------------------------------------------------------------------------------------------