Task 1 :- Create topology as given in pic

Task 2 :- Configure ip address given topology

Task 3 :- Configure loopback According given topology

Task 4 :- Configure OSPF AS 10 / AREA 0

Task 5 :- Check communication in R1 to R4 

-----------------------------------------------------------------------------------------------------

 Task 1 :- Create topology as given in pi

----------------------------------------------------------------------------------------------------------

Task 2 :- Configure ip address given topology

R1

R1(config)#
R1(config)#interface fastEthernet 0/0
R1(config-if)#
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#


R2


R2(config)#
R2(config)#interface fastEthernet 0/0
R2(config-if)#
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#


R3

 
R3(config)#
R3(config)#interface fastEthernet 0/0
R3(config-if)#
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#


R4

R4(config)#
R4(config)#interface fastEthernet 0/0
R4(config-if)#
R4(config-if)#ip address 192.168.1.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#



----------------------------------------------------------------------------------------------------------

 Task 3 :- Configure loopback According given topology

R1
 
R1(config)
R1(config)#interface loopback 0
R1(config-if)#
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#


R2

R2(config)
R2(config)#interface loopback 0
R2(config-if)#
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#exit
R2(config)#


R3

R3(config)
R3(config)#interface loopback 0
R3(config-if)#
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#
 


R4


R4(config)
R4(config)#interface loopback 0
R4(config-if)#
R4(config-if)#ip address 4.4.4.4 255.255.255.0
R4(config-if)#exit
R4(config)#

-----------------------------------------------------------------------------------------------------

 
Task 4 :- Configure OSPF AS 10 / AREA 0


R1

R1(config)#router ospf 10
R1(config-router)#
R1(config-router)#network 192.168.1.0 0.0.0.255 are 0
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#
 


R2

R2(config)#router ospf 10
R2(config-router)#
R2(config-router)#network 192.168.1.0 0.0.0.255 are 0
R2(config-router)#network 2.2.2.0 0.0.0.255 area 0
R2(config-router)#
 


R3

R3(config)#router ospf 10
R3(config-router)#
R3(config-router)#network 192.168.1.0 0.0.0.255 are 0
R3(config-router)#network 3.3.3.0 0.0.0.255 area 0
R3(config-router)#



R4

R4(config)#router ospf 10
R4(config-router)#
R4(config-router)#network 192.168.1.0 0.0.0.255 are 0
R4(config-router)#network 4.4.4.0.0.0.255 area 0
R4(config-router)#

---------------------------------------------------------------------------------------------------

Task 5 :- Check communication in R1 to R4 

R1#ping 4.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/41/72 ms
R1#

---------------------------------------------------------------------------------------------------

 Now check which Router is DR Router..


R1#show ip ospf neighbor

Neighbor ID     Pri           State                Dead Time   Address         Interface
2.2.2.2              1   2WAY/DROTHER    00:00:31    192.168.1.2     FastEthernet0/0
3.3.3.3              1   FULL/BDR               00:00:38    192.168.1.3     FastEthernet0/0
4.4.4.4              1   FULL/DR                 00:00:37    192.168.1.4     FastEthernet0/0
R1#
 

Here We can see R4 is DR Router by default Election base on the highest loopback address 

-------------------------------------------------------------------------------------------------

If  Admin Wants to make DR R2 Let's look ( Change ROUTER ID)


goto R2
 
R2(config)#
R2(config)#router ospf 10
R2(config-router)#
R2(config-router)#router-id 10.10.10.10
Reload or use "clear ip ospf process" command, for this to take effect
R2(config-router)#
R2(config-router)#exit
R2#

R2#clear ip ospf process
Reset ALL OSPF processes? [no]: y
R2#


here we give Highest Router id to R2 Now after election Router 2 will become DR Router


R1#show ip ospf  neigbhor

Neighbor ID     Pri   State                       Dead Time   Address         Interface
3.3.3.3              1    2WAY/DROTHER  00:00:31    192.168.1.3     FastEthernet0/0
4.4.4.4              1    EXSTART/BDR      00:00:38    192.168.1.4     FastEthernet0/0
10.10.10.10      1    FULL/DR               00:00:36    192.168.1.2     FastEthernet0/0
R1#


here 10.10.10.10 is R2 ROUTER ID AND R2 is DR

-------------------------------------------------------------------------------------------------

Change priority to make R1 DR

R1 

R1(config)#
R1(config)#interface fastEthernet 0/0
R1(config-if)#
R1(config-if)#ip ospf priority ?
  <0-255>  Priority

R1(config-if)#ip ospf priority 255
R1(config-if)#
R1(config-if)#

 


R4#show ip ospf neighbor

Neighbor ID     Pri        State                          Dead Time   Address         Interface
1.1.1.1             255       FULL/DR                  00:00:34    192.168.1.1     FastEthernet0/0
3.3.3.3             1           2WAY/DROTHER    00:00:31    192.168.1.3     FastEthernet0/0
10.10.10.10     1           FULL/BDR               00:00:39    192.168.1.2     FastEthernet0/0
R4#







 

  
---------------------------------------------------------------------------------------------------------