Task 1 :- Create topology as given in pic.
Task 2 :- Configure ip address given topology.
Task 3 :- Configure host ip given topology.
Task 4 :- Configure RIP protocol.
Task 5 :- Check communication in host to server.
Task 6 :- Enable DYNAMIC NAT.
Task 7 :- check NAT TABLE.
------------------------------------------------------------------------------------------------------------------
Task 1 :- Create topology as given in pic.
--------------------------------------------------------------------------------------------------------------
Task 2 :- Configure ip address given topology.
R1
R1#configure terminal
R1(config)#
R1(config)#interface fastEthernet 0/1
R1(config-if)#
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int
*Mar 1 00:06:18.411: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar 1 00:06:19.411: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config)#
R1(config)#interface fastEthernet 0/0
R1(config-if)#
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:06:34.363: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:06:35.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#
R2
R2#
R2#Configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#interface fastEthernet 0/0
R2(config-if)#
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
R2(config)#
*Mar 1 00:08:57.903: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:08:58.903: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config)#interface fastEthernet 0/1
R2(config-if)#
R2(config-if)#ip address 100.1.1.1 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
--------------------------------------------------------------------------------------------------------------
Task 3 :- Configure host ip given topology.
give IP address 192.168.1.2 as we give in pc or laptop .. same as in server 100.1.1.2
--------------------------------------------------------------------------------------------------------------
Task 4 :- Configure RIP protocol.
R1
R1(config)#
R1(config)#router rip
R1(config-router)#
R1(config-router)#network 192.168.1.0
R1(config-router)#network 10.1.1.0
R1(config-router)#
R1(config-router)#no auto-summary
R1(config-router)#
R1(config-router)#version 2
R1(config-router)#
R2
R2(config)#
R2(config)#router rip
R2(config-router)#
R2(config-router)#network 10.1.1.0
R2(config-router)#network 100.1.1.0
R2(config-router)#
R2(config-router)#no auto-summary
R2(config-router)#
R2(config-router)#version 2
R2(config-router)#
--------------------------------------------------------------------------------------------------------------
Task 5 :- Check communication in host to server.
PC#ping 100.1.1.2 !! this is Server ip !!
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/85/100 ms\
--------------------------------------------------------------------------------------------------------------
Task 6 :- Enable DYNAMIC NAT.
R1
First create Access list and given network
R1(config)#access-list 101 permit ip 192.168.1.0 0.0.0.255 any
now Create NAT Pool
R1(config)#ip nat pool ccna 172.16.1.1 172.16.1.4 netmask 255.255.255.0
now create Dynamic NAT
R1(config)#ip nat inside source list 101 pool ccna
apply on interface
R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip nat inside
R1(config)# interface fastEthernet0/1
R1(config-if)#ip nat outside
---------------------------------------------------------------------------------------------------------------
Task 2 :- Configure ip address given topology.
Task 3 :- Configure host ip given topology.
Task 4 :- Configure RIP protocol.
Task 5 :- Check communication in host to server.
Task 6 :- Enable DYNAMIC NAT.
Task 7 :- check NAT TABLE.
------------------------------------------------------------------------------------------------------------------
Task 1 :- Create topology as given in pic.
--------------------------------------------------------------------------------------------------------------
Task 2 :- Configure ip address given topology.
R1
R1#configure terminal
R1(config)#
R1(config)#interface fastEthernet 0/1
R1(config-if)#
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int
*Mar 1 00:06:18.411: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar 1 00:06:19.411: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config)#
R1(config)#interface fastEthernet 0/0
R1(config-if)#
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:06:34.363: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:06:35.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#
R2
R2#
R2#Configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#interface fastEthernet 0/0
R2(config-if)#
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
R2(config)#
*Mar 1 00:08:57.903: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:08:58.903: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config)#interface fastEthernet 0/1
R2(config-if)#
R2(config-if)#ip address 100.1.1.1 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
--------------------------------------------------------------------------------------------------------------
Task 3 :- Configure host ip given topology.
give IP address 192.168.1.2 as we give in pc or laptop .. same as in server 100.1.1.2
--------------------------------------------------------------------------------------------------------------
Task 4 :- Configure RIP protocol.
R1
R1(config)#
R1(config)#router rip
R1(config-router)#
R1(config-router)#network 192.168.1.0
R1(config-router)#network 10.1.1.0
R1(config-router)#
R1(config-router)#no auto-summary
R1(config-router)#
R1(config-router)#version 2
R1(config-router)#
R2
R2(config)#
R2(config)#router rip
R2(config-router)#
R2(config-router)#network 10.1.1.0
R2(config-router)#network 100.1.1.0
R2(config-router)#
R2(config-router)#no auto-summary
R2(config-router)#
R2(config-router)#version 2
R2(config-router)#
--------------------------------------------------------------------------------------------------------------
Task 5 :- Check communication in host to server.
PC#ping 100.1.1.2 !! this is Server ip !!
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/85/100 ms\
--------------------------------------------------------------------------------------------------------------
Task 6 :- Enable DYNAMIC NAT.
R1
First create Access list and given network
R1(config)#access-list 101 permit ip 192.168.1.0 0.0.0.255 any
now Create NAT Pool
R1(config)#ip nat pool ccna 172.16.1.1 172.16.1.4 netmask 255.255.255.0
now create Dynamic NAT
R1(config)#ip nat inside source list 101 pool ccna
apply on interface
R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip nat inside
R1(config)# interface fastEthernet0/1
R1(config-if)#ip nat outside
---------------------------------------------------------------------------------------------------------------
Social Plugin