Configure RIP Default Route..

Task 1 :-  Configure IP Address According topology.

Task 2 :-  Configure loopback Address on R1,R2,R3.

Task 3 :-  Configure RIP on R1,R2,R3

Task 4 :-  Apply Authentication between R1,R3 (MD5,plane text )

Task 5 :-  Make sure R1 can reach R3 

-----------------------------------------------------------------------------------------------------------------------------------

Task 1 :-  Configure IP Address According topology.
 
R1  Configuration....

R1#
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#interface ethernet 0/0
R1(config-if)#

R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#

R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int
*Apr 27 09:22:12.031: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Apr 27 09:22:13.037: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up
R1(config)#
R1(config)#interface ethernet 0/1
R1(config-if)#
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Apr 27 09:22:35.714: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Apr 27 09:22:36.720: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up
R1(config)#
 


R2 Configuration...

R2#
R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#interface ethernet 0/0
R2(config-if)#

R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
*Apr 27 09:25:41.695: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Apr 27 09:25:42.700: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to upt
R2(config)#
R2(config)#interface serial 2/0
R2(config-if)#

R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#

R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
R2(config)#
R2(config)#
*Apr 27 09:26:08.812: %LINK-3-UPDOWN: Interface Serial2/0, changed state to up
*Apr 27 09:26:09.813: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config)#
 


R3 Configuration...

R3#
R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#

R3(config)#interface ethernet 0/1
R3(config-if)#
R3(config-if)#ip address 192.168.13.3 255.255.255.0
R3(config-if)#
R3(config-if)#no shutdown
R3(config-if)#exit



*Apr 27 09:28:41.642: %LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
*Apr 27 09:28:42.651: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to up

R3(config)#interface serial 2/0
R3(config-if)#
R3(config-if)#ip address 192.168.23.2 255.255.255.0
R3(config-if)#
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#



-----------------------------------------------------------------------------------------------------------------------------------

 Task 2 :-  Configure loopback Address on R1,R2,R3.

R1 configuration.. 

R1(config)#
R1(config)#interface loopback 1
R1(config-if)#
*Apr 27 09:32:17.301: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#


R2 configuration..

R2(config)#
R2(config)#interface loopback 1
R2(config-if)#
*Apr 27 09:32:32.545: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#exit
R2(config)# 


 
R3 configuration..

R3(config)#
R3(config)#interface loopback 1
R3(config-if)#
*Apr 27 09:32:32.545: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)# 


 -----------------------------------------------------------------------------------------------------------------------------------

 Task 3 :-  Configure RIP Default Route on R1,R2,R3

R1 Configuration...

R1(config)#
R1(config)#
R1(config)#router rip
R1(config-router)#
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.13.0

R1(config-router)#no auto-summary
R1(config-router)#
R1(config-router)#version 2
R1(config-router)#
R1(config-router)#


!! in The Default Route 0.0.0.0 in this command router Advertise all subnets of Router !! 

R2 Configuration...

R2(config)#
R2(config)#
R2(config)#router rip
R2(config-router)#
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0
R2(config-router)#no auto-summary
R2(config-router)#
R2(config-router)#version 2
R2(config-router)#
R2(config-router)#


R3 Configuration...

R3(config)#
R3(config)#
R3(config)#router rip
R3(config-router)#
R3(config-router)#network 192.168.13.0
R3(config-router)#network 192.168.23.0
R3(config-router)#no auto-summary
R3(config-router)#
R3(config-router)#version 2
R3(config-router)#
R3(config-router)#


-----------------------------------------------------------------------------------------------------------------------------------

Routing Table

R1

R1#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/24 is subnetted, 1 subnets
R        2.2.2.0 [120/1] via 192.168.12.2, 00:00:10, Ethernet0/0
      3.0.0.0/24 is subnetted, 1 subnets
R        3.3.3.0 [120/1] via 192.168.13.3, 00:00:02, Ethernet0/1
R     192.168.23.0/24 [120/1] via 192.168.13.3, 00:00:02, Ethernet0/1
                      [120/1] via 192.168.12.2, 00:00:10, Ethernet0/0

R1#




 

Same As R2 and R3

 
-----------------------------------------------------------------------------------------------------------------------------------

Task 4 :-  Apply Authentication between R1,R3 (MD5,plane text ) 

R1   Configuration..

R1#
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#key chain ?
  WORD  Key-chain name

R1(config)#key chain cisco
R1(config-keychain)#key 1
R1(config-keychain-key)#
R1(config-keychain-key)#key-string CCNA
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#

R1(config)#interface ethernet 0/1
R1(config-if)#

R1(config-if)#ip rip authentication mode ?
  md5   Keyed message digest
  text  Clear text authentication

 

R1(config-if)#ip rip authentication mode md5
R1(config-if)#
R1(config-if)#ip rip authentication key-chain cisco
R1(config-if)#
 


R3 Configuration..

R3(config)#
R3(config)#key chain cisco
R3(config-keychain)#key 1
R3(config-keychain-key)#key-string CCNA
R3(config-keychain-key)#exit
R3(config-keychain)#exit
R3(config)#

R3(config)#interface ethernet 0/1
R3(config-if)#
R3(config-if)#ip rip authentication mode md5
R3(config-if)#

R3(config-if)#ip rip authentication key-chain cisco
R3(config-if)#exit
R3(config)#



-----------------------------------------------------------------------------------------------------------------------------------

Task 5 :-  Make sure R1 can reach R3 

R3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/10 ms
R3#


R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/9 ms
R1#


-----------------------------------------------------------------------------------------------------------------------------------