Auto summarization
Task 1 :- Configure IP Address according topology
Task 2 :- Conifgure loopback Address
Task 3 :- Configure RIP
Task 4 :- Make sure IOU1(R1) are on Auto summarization
---------------------------------------------------------------------------------------------------------------------------------
Task 1 :- Configure IP Address according topology
Router IOU1 configuration...
IOU1#
IOU1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
IOU1(config)#
IOU1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
IOU1(config)#
IOU1(config)#interface ethernet 0/0
IOU1(config-if)#
IOU1(config-if)#ip address 192.168.12.1 255.255.255.0
IOU1(config-if)#
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#
IOU1(config-if)#
IOU1(config-if)#ip address 192.168.12.1 255.255.255.0
IOU1(config-if)#
IOU1(config-if)#no shutdown
IOU1(config-if)#exit
IOU1(config)#
Router IOU2 configuration...
IOU2#
IOU2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
IOU2(config)#
IOU2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
IOU2(config)#
IOU2(config)#interface ethernet 0/0
IOU2(config-if)#
IOU2(config-if)#ip address 192.168.12.2 255.255.255.0
IOU2(config-if)#
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#
IOU2(config-if)#
IOU2(config-if)#ip address 192.168.12.2 255.255.255.0
IOU2(config-if)#
IOU2(config-if)#no shutdown
IOU2(config-if)#exit
IOU2(config)#
---------------------------------------------------------------------------------------------------------------------------------
Task 2 :- Conifgure loopback Address
Router IOU1 configuration...
IOU1(config)#
IOU1(config)#interface loopback 1
IOU1(config-if)#ip address 10.1.1.1 255.255.255.0
IOU1(config-if)#exit
IOU1(config)#interface loopback 2
IOU1(config-if)#
IOU1(config-if)#ip address 10.1.2.1 255.255.255.0
IOU1(config-if)#exit
IOU1(config)#interface loopback 3
IOU1(config-if)#
IOU1(config-if)#ip address 10.1.1.1 255.255.255.0
IOU1(config-if)#exit
IOU1(config)#interface loopback 2
IOU1(config-if)#
IOU1(config-if)#ip address 10.1.2.1 255.255.255.0
IOU1(config-if)#exit
IOU1(config)#interface loopback 3
IOU1(config-if)#
IOU1(config-if)#ip address 10.1.3.1 255.255.255.0
IOU1(config-if)#exit
IOU1(config)#interface loopback 4
IOU1(config-if)#
IOU1(config-if)#exit
IOU1(config)#interface loopback 4
IOU1(config-if)#
IOU1(config-if)#ip address 10.1.4.1 255.255.255.0
IOU1(config-if)#exit
IOU1(config)#interface loopback 5
IOU1(config-if)#
IOU1(config-if)#exit
IOU1(config)#interface loopback 5
IOU1(config-if)#
IOU1(config-if)#ip address 10.1.5.1 255.255.255.0
IOU1(config-if)#exit
IOU1(config)#
IOU1(config-if)#exit
IOU1(config)#
---------------------------------------------------------------------------------------------------------------------------------
Task 3 :- Configure RIP
Router IOU1 configuration...
IOU1(config)#
IOU1(config)#router rip
IOU1(config-router)#network 192.168.12.0
IOU1(config-router)#network 10.1.1.0
IOU1(config-router)#network 10.1.2.0
IOU1(config-router)#network 10.1.3.0
IOU1(config-router)#network 10.1.4.0
IOU1(config-router)#network 10.1.5.0
IOU1(config-router)#
IOU1(config-router)#version 2
IOU1(config-router)#
IOU1(config)#router rip
IOU1(config-router)#network 192.168.12.0
IOU1(config-router)#network 10.1.1.0
IOU1(config-router)#network 10.1.2.0
IOU1(config-router)#network 10.1.3.0
IOU1(config-router)#network 10.1.4.0
IOU1(config-router)#network 10.1.5.0
IOU1(config-router)#
IOU1(config-router)#version 2
IOU1(config-router)#
!! here We can see there in no any no auto summary command we are doing Auto summarization !!
Router IOU2 configuration...
IOU2(config)#
IOU2(config)#router rip
IOU2(config-router)#network 192.168.12.0
IOU2(config-router)#
IOU2(config-router)#version 2
IOU2(config-router)#
IOU2(config)#router rip
IOU2(config-router)#network 192.168.12.0
IOU2(config-router)#
IOU2(config-router)#version 2
IOU2(config-router)#
---------------------------------------------------------------------------------------------------------------------------------
Task 4 :- Make sure IOU1(R1) are on Auto summarization
IOU2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
R 10.0.0.0/8[120/1] via 192.168.12.1, 00:00:18, Ethernet0/0
IOU2#
!! Routing table route is 10.0.0./8 but we adverstise on 10.1.1.0/24 here they performer by default Auto summarization !!
When we use " no auto summary command "
IOU1(config)#router rip
IOU1(config-router)#no auto-summary
IOU1(config-router)#
IOU1(config-router)#no auto-summary
IOU1(config-router)#
let's look
IOU2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 5 subnets
R 10.1.1.0 [120/1] via 192.168.12.1, 00:00:05, Ethernet0/0
R 10.1.2.0 [120/1] via 192.168.12.1, 00:00:05, Ethernet0/0
R 10.1.3.0 [120/1] via 192.168.12.1, 00:00:05, Ethernet0/0
R 10.1.4.0 [120/1] via 192.168.12.1, 00:00:05, Ethernet0/0
R 10.1.5.0 [120/1] via 192.168.12.1, 00:00:05, Ethernet0/0
IOU2#
every route are coming individual
---------------------------------------------------------------------------------------------------------------------------------
manual summarization
Q :- how to find manual summarization
we have....
10.1.1.0
10.1.2.0
10.1.3.0
10.1.4.0
10.1.5.0
let's take first and last subnets
10.1.1.0
10.1.5.0
10.1
10.1 are both same means 2 octet's same
8 bit each octat's
8+8 = 16
now binary of
1 = 00000001
5 = 00000101
here we have 5 bit match
16 + 5 = 21
10.1.0.0/21 this our summarize route
assign summarize route on Router
Router IOU1 Configuration ....
IOU1(config)#
IOU1(config)#interface ethernet 0/0
IOU1(config-if)#
IOU1(config)#interface ethernet 0/0
IOU1(config-if)#
IOU1(config-if)#ip summary-address rip 10.1.0.0 255.255.248.0 !! this is the subnetmask of /21 !!
IOU1(config-if)#
IOU1(config-if)#
let's check .,,
IOU2#show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
10.0.0.0/21 is subnetted, 1 subnets
R 10.1.0.0 [120/1] via 192.168.12.1, 00:00:13, Ethernet0/0
IOU2#
---------------------------------------------------------------------------------------------------------------------------------
Social Plugin