Note :- R1 and R3 have only one exit interface, default Router will advertise only on R1 and R3 


Task 1 :- Configure IP Address according topology

Task 2 :- Configure loopback Address according topology

Task 3 :-  Configure Static Route on R2 , give Default Route on R1 and R3

Task 4 :-  check the reachability between R1 to R3 loopback 

---------------------------------------------------------------------------------------------------------------------


Task 1 :- Configure IP Address according topology

R1 configuration ...

R1#
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#interface fastEthernet 0/0
R1(config-if)#
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#

R2 configuration ...

R2#
R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#interface fastEthernet 0/0
R2(config-if)#
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Mar  1 00:11:19.851: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:11:20.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config)#
R2(config)#interface fastEthernet 0/1
R2(config-if)#
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
R2(config-if)#exit
R2#

R3 configuration ...

R3#
R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#
R3(config)#interface fastEthernet 0/0
R3(config-if)#
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#
R3(config-if)#no shutdown
R3(config-if)#
R3(config-if)#exit
R3(config)#

---------------------------------------------------------------------------------------------------------------------  


 Task 2 :- Configure loopback Address according topology

R1 configuration....

R1(config)#
R1(config)#interface loopback 1
R1(config-if)# 

*Mar  1 00:17:15.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#
R1(config-if)#exit
R1(config)#
 
R2 configuration...


R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#interface loopback 1
R2(config-if)#
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#

R3 configuration...

R3(config)#
R3(config)#interface loopback 1
R3(config-if)#

*Mar  1 00:18:06.431: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#

---------------------------------------------------------------------------------------------------------------------  


Task 3 :-  Configure Static Route on R2 , give Default Route on R1 and R3

R1 configuration ....


R1(config)#
R1(config)#
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.12.2
R1(config)#exit

R1#show ip route static 

S*   0.0.0.0/0 [1/0] via 192.168.12.2
R1#
 

R2 configuration....

R2(config)#
R2(config)#ip route 1.1.1.0 255.255.255.0 192.168.12.1
R2(config)#ip route 3.3.3.0 255.255.255.0 192.168.23.3
R2(config)#exit

R2#show ip route static
     1.0.0.0/24 is subnetted, 1 subnets
S       1.1.1.0 [1/0] via 192.168.12.1
     3.0.0.0/24 is subnetted, 1 subnets
S       3.3.3.0 [1/0] via 192.168.23.3
R2#

R3 configuration....
 
R3(config)#
R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.2
R3(config)#exit

R3#show ip route static
 
S*   0.0.0.0/0 [1/0] via 192.168.23.2
R3#
 ---------------------------------------------------------------------------------------------------------------------  


 Task 4 :-  check the reachability between R1 to R3 loopback 

R1#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 184/204/264 ms
R1#


---------------------------------------------------------------------------------------------------------------------