Configure RIP timers

Task 1:- Configure IP Address according topology

Task 2:- Configure loopback on R1,R2

Task 3:- Configure RIPv2

Task 4:- Make sure R1 can reach R2

Task 5:- Check by default RIP timers

Task 6:- Change RIP timers

----------------------------------------------------------------------------------------------------------------------------------

 Task 1:- Configure IP Address according topology

R1 Configuration....

R1#
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#

R1(config)#interface ethernet 0/0
R1(config-if)#
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#



R2 Configuration....

R2#
R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#interface ethernet 0/0
R2(config-if)#
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#

----------------------------------------------------------------------------------------------------------------------------------


Task 2:- Configure loopback on R1,R2


R1 Configuration....

R1(config)#
R1(config)#interface loopback 1
R1(config-if)#
*Apr 28 08:09:22.307: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#


R2 Configuration....

R2(config)#
R2(config)#interface loopback 1
R2(config-if)#
*Apr 28 08:09:22.307: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#


----------------------------------------------------------------------------------------------------------------------------------

Task 3:- Configure RIPv2

R1 Configuration....

R1(config)#
R1(config)#
R1(config)#router rip
R1(config-router)#network 192.168.12.0
R1(config-router)#network 1.1.1.0
R1(config-router)#
R1(config-router)#no auto-summary
R1(config-router)#
R1(config-router)#version 2
R1(config-router)#






R2 Configuration....


R2(config)#
R2(config)#
R2(config)#router rip
R2(config-router)#network 192.168.12.0
R2(config-router)#network 2.2.2.0
R2(config-router)#
R2(config-router)#no auto-summary
R2(config-router)#
R2(config-router)#version 2
R2(config-router)#


----------------------------------------------------------------------------------------------------------------------------------

 Task 5:- Check by default RIP timers

R1...

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 25 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240

  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0/0           2     2                                   
    Loopback1             2     2                                   
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    192.168.12.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

R1#
R1#


----------------------------------------------------------------------------------------------------------------------------------

Task 6:- Change RIP timers

R1....  

R1#
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#router rip
R1(config-router)#
R1(config-router)#
R1(config-router)#timers basic 10 ?    !! Basic consider Hello time !!
  <1-2147483>  Invalid

R1(config-router)#timers basic 10 100 ?
  <0-2147483>  Holddown

R1(config-router)#timers basic 10 100 100 ?
  <1-2147483>  Flush

R1(config-router)#timers basic 10 100 100 150
R1(config-router)#
 


----------------------------------------------------------------------------------------------------------------------------------

Task 5:- Check by changes RIP timers


R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 10 seconds, next due in 8 seconds
  Invalid after 100 seconds, hold down 100, flushed after 150

  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0/0           2     2                                   
    Loopback1             2     2                                   
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    192.168.12.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

R1#
 



----------------------------------------------------------------------------------------------------------------------------------