Configure Static load balancing :-


Task 1 :- configure IP ADDRESS according topology

Task 2 :- configure loopback address on Router

Task 3 :- Configure Static Route on R1 and R2

Task 4 :- check both loopback reachability 

Task 5 :- configure conditional Static Route 


-----------------------------------------------------------------------------------------------------------------

 Task 1 :- configure IP ADDRESS according topology

 R1 configuration 

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 20.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar  1 00:50:56.955: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:50:57.955: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


R1(config)#interface fastEthernet 0/1
R1(config-if)#
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
*Mar  1 00:51:12.523: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar  1 00:51:13.523: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up



R2 configuration 

R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 20.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
R2(config)#

*Mar  1 01:50:01.827: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 01:50:02.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


R2(config)#interface fastEthernet 0/1
R2(config-if)#
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown

R2(config-if)#exit
R2(config)#



-----------------------------------------------------------------------------------------------------------------


Task 2 :- configure loopback address on Router

R1 configuration 

R1(config)#
R1(config)#interface loopback 1
R1(config-if)#
R1(config-if)#*Mar  1 01:52:29.335: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up


R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#


R2 configuration 

R2(config)#
R2(config)#interface loopback 1
R2(config-if)#
*Mar  1 01:53:55.527: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up

R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#
R2(config-if)#exit
R2(config)#


-----------------------------------------------------------------------------------------------------------------

 Task 3 :- Configure Static Route on R1 and R2

 R1 configuration 

R1(config)#
R1(config)#ip route 2.2.2.0 255.255.255.0 10.1.1.2
R1(config)#ip route 2.2.2.0 255.255.255.0 20.1.1.2
R1(config)#exit

R1#show ip route static 

     2.0.0.0/24 is subnetted, 1 subnets
S       2.2.2.0 [1/0] via 20.1.1.2
                    [1/0] via 10.1.1.2

R1#


 R2 configuration 

R2(config)#
R2(config)#ip route 1.1.1.0 255.255.255.0 10.1.1.1
R2(config)#ip route 1.1.1.0 255.255.255.0 20.1.1.1
R2(config)#exi
t


R2#show ip route static
     1.0.0.0/24 is subnetted, 1 subnets
S       1.1.1.0 [1/0] via 20.1.1.1
                    [1/0] via 10.1.1.1 !! here we can see to reach 1.1.1.0/24 we have two path !!

 
R2#


 


-----------------------------------------------------------------------------------------------------------------


 Task 4 :- check both loopback reachability 

ping R1 loopback to r2 loopback

R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/45/92 ms
R1#


   traceroute command

R1#traceroute 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 20.1.1.2 64 msec
    10.1.1.2 64 msec
    20.1.1.2 96 msec
R1#


 -----------------------------------------------------------------------------------------------------------------

 Task 5 :- configure conditional Static Route

Q :-  if we want first path best end second  patch for backup how can route modify 
 
R1 route table


R1#show ip route static
     2.0.0.0/24 is subnetted, 1 subnets
S       2.2.2.0 [1/0] via 20.1.1.2
                    [1/0] via 10.1.1.2
R1#


 if user required master path 10.1.1.2 backup path 20.1.1.2 let's modify

R1 configuration 

R1(config)# no ip route 2.2.2.0 255.255.255.0 20.1.1.2
R1(config)#
R1(config)# ip route 2.2.2.0 255.255.255.0 20.1.1.2 100  


!! here we increase  AD Value  100 !!
R1(config)#
R1(config)#exit


R1#show ip route static
     2.0.0.0/24 is subnetted, 1 subnets
S       2.2.2.0 [1/0] via 10.1.1.2
R1#


traceroute..

R1#traceroute 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

  1 10.1.1.2 72 msec 60 msec 32 msec
R1#