Configure passive interface
Task 1:- Configure IP Address according topology
Task 2:- Configure loopback Address on both Router
Task 3:- Configure RIPv2 on R1,R2
Task 4:- Make sure R1 can ping R2 loopback
Task 5:- Debug RIP updates
Task 6:- stop loopback update with passive interface
---------------------------------------------------------------------------------------------------------------------------------------
Task 1:- Configure IP Address according topology
R1 configuration
R1#
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface ethernet 0/0
R1(config-if)#
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R2 configuration
R2#
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#interface ethernet 0/0
R2(config-if)#
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
--------------------------------------------------------------------------------------------------------------------------------------
Task 2:- Configure loopback Address on both Router
R1 configuration
R1#
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#interface loopback 1
R1(config-if)#i
*Apr 29 09:09:51.188: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
R2 configuration
R2(config)#
R2(config)#interface loopback 1
R2(config-if)#
*Apr 29 09:10:54.512: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
--------------------------------------------------------------------------------------------------------------------------------------
Task 3:- Configure RIPv2 on R1,R2
R1 configuration
R1(config)#
R1(config)#router rip
R1(config-router)#network 192.168.12.0
R1(config-router)#network 1.1.1.0
R1(config-router)#
R1(config-router)#no auto-summary
R1(config-router)#
R1(config-router)#version 2
R1(config-router)#
R2 configuration
R2(config)#
R2(config)#router rip
R2(config-router)#network 192.168.12.0
R2(config-router)#network 2.2.2.0
R2(config-router)#
R2(config-router)#no auto-summary
R2(config-router)#
R2(config-router)#version 2
R2(config-router)#
--------------------------------------------------------------------------------------------------------------------------------------
Task 4:- Make sure R1 can ping R2 loopback
R1#ping 2.2.2.2
*Apr 29 09:17:21.317: %SYS-5-CONFIG_I: Configured from console by console
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/7 ms
R1#
--------------------------------------------------------------------------------------------------------------------------------------
Task 5:- Debug RIP updates
R1#debug ip rip events
RIP event debugging is on
R1#
R1#
R1#
R1#
*Apr 29 09:24:15.162: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (192.168.12.1)
*Apr 29 09:24:15.162: RIP: Update contains 1 routes
*Apr 29 09:24:15.162: RIP: Update queued
*Apr 29 09:24:15.162: RIP: Update sent via Ethernet0/0
R1#
*Apr 29 09:24:27.070: RIP: sending v2 update to 224.0.0.9 via Loopback1 (1.1.1.1)
*Apr 29 09:24:27.070: RIP: Update contains 2 routes
*Apr 29 09:24:27.070: RIP: Update queued
*Apr 29 09:24:27.070: RIP: Update sent via Loopback1
*Apr 29 09:24:27.071: RIP: ignored v2 packet from 1.1.1.1 (sourced from one of our addresses)
R1#
*Apr 29 09:24:29.154: RIP: received v2 update from 192.168.12.2 on Ethernet0/0
*Apr 29 09:24:29.154: RIP: Update contains 1 routes
R1#
*Apr 29 09:24:43.538: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (192.168.12.1)
*Apr 29 09:24:43.538: RIP: Update contains 1 routes
*Apr 29 09:24:43.538: RIP: Update queued
*Apr 29 09:24:43.538: RIP: Update sent via Ethernet0/0
R1#u all
All possible debugging has been turned off
R1#
R1#
R1#
!! here we can see Loopback is all so sending updates to R2 but there is no required of loopback updates now stop the loopback updates !!
--------------------------------------------------------------------------------------------------------------------------------------
Task 6:- stop loopback update with passive interface
R1(config)#router rip
R1(config-router)#
R1(config-router)#passive-interface loopback 1
R1(config-router)#
R1#debug ip rip events
RIP event debugging is on
R1#
*Apr 29 09:31:42.913: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (192.168.12.1)
*Apr 29 09:31:42.914: RIP: Update contains 1 routes
*Apr 29 09:31:42.914: RIP: Update queued
*Apr 29 09:31:42.914: RIP: Update sent via Ethernet0/0
R1#
*Apr 29 09:31:49.534: RIP: received v2 update from 192.168.12.2 on Ethernet0/0
*Apr 29 09:31:49.534: RIP: Update contains 1 routes
R1#
*Apr 29 09:32:10.301: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (192.168.12.1)
*Apr 29 09:32:10.301: RIP: Update contains 1 routes
*Apr 29 09:32:10.301: RIP: Update queued
*Apr 29 09:32:10.302: RIP: Update sent via Ethernet0/0
R1#u all
All possible debugging has been turned off
!! here we can see there no any updates of loopback only we have NIC port !!
--------------------------------------------------------------------------------------------------------------------------------------
Task 1:- Configure IP Address according topology
Task 2:- Configure loopback Address on both Router
Task 3:- Configure RIPv2 on R1,R2
Task 4:- Make sure R1 can ping R2 loopback
Task 5:- Debug RIP updates
Task 6:- stop loopback update with passive interface
---------------------------------------------------------------------------------------------------------------------------------------
Task 1:- Configure IP Address according topology
R1 configuration
R1#
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface ethernet 0/0
R1(config-if)#
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R2 configuration
R2#
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#interface ethernet 0/0
R2(config-if)#
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
--------------------------------------------------------------------------------------------------------------------------------------
Task 2:- Configure loopback Address on both Router
R1 configuration
R1#
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#interface loopback 1
R1(config-if)#i
*Apr 29 09:09:51.188: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R1(config-if)#
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
R2 configuration
R2(config)#
R2(config)#interface loopback 1
R2(config-if)#
*Apr 29 09:10:54.512: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
--------------------------------------------------------------------------------------------------------------------------------------
Task 3:- Configure RIPv2 on R1,R2
R1 configuration
R1(config)#
R1(config)#router rip
R1(config-router)#network 192.168.12.0
R1(config-router)#network 1.1.1.0
R1(config-router)#
R1(config-router)#no auto-summary
R1(config-router)#
R1(config-router)#version 2
R1(config-router)#
R2 configuration
R2(config)#
R2(config)#router rip
R2(config-router)#network 192.168.12.0
R2(config-router)#network 2.2.2.0
R2(config-router)#
R2(config-router)#no auto-summary
R2(config-router)#
R2(config-router)#version 2
R2(config-router)#
--------------------------------------------------------------------------------------------------------------------------------------
Task 4:- Make sure R1 can ping R2 loopback
R1#ping 2.2.2.2
*Apr 29 09:17:21.317: %SYS-5-CONFIG_I: Configured from console by console
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/7 ms
R1#
--------------------------------------------------------------------------------------------------------------------------------------
Task 5:- Debug RIP updates
R1#debug ip rip events
RIP event debugging is on
R1#
R1#
R1#
R1#
*Apr 29 09:24:15.162: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (192.168.12.1)
*Apr 29 09:24:15.162: RIP: Update contains 1 routes
*Apr 29 09:24:15.162: RIP: Update queued
*Apr 29 09:24:15.162: RIP: Update sent via Ethernet0/0
R1#
*Apr 29 09:24:27.070: RIP: sending v2 update to 224.0.0.9 via Loopback1 (1.1.1.1)
*Apr 29 09:24:27.070: RIP: Update contains 2 routes
*Apr 29 09:24:27.070: RIP: Update queued
*Apr 29 09:24:27.070: RIP: Update sent via Loopback1
*Apr 29 09:24:27.071: RIP: ignored v2 packet from 1.1.1.1 (sourced from one of our addresses)
R1#
*Apr 29 09:24:29.154: RIP: received v2 update from 192.168.12.2 on Ethernet0/0
*Apr 29 09:24:29.154: RIP: Update contains 1 routes
R1#
*Apr 29 09:24:43.538: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (192.168.12.1)
*Apr 29 09:24:43.538: RIP: Update contains 1 routes
*Apr 29 09:24:43.538: RIP: Update queued
*Apr 29 09:24:43.538: RIP: Update sent via Ethernet0/0
R1#u all
All possible debugging has been turned off
R1#
R1#
R1#
!! here we can see Loopback is all so sending updates to R2 but there is no required of loopback updates now stop the loopback updates !!
--------------------------------------------------------------------------------------------------------------------------------------
Task 6:- stop loopback update with passive interface
R1(config)#router rip
R1(config-router)#
R1(config-router)#passive-interface loopback 1
R1(config-router)#
R1#debug ip rip events
RIP event debugging is on
R1#
*Apr 29 09:31:42.913: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (192.168.12.1)
*Apr 29 09:31:42.914: RIP: Update contains 1 routes
*Apr 29 09:31:42.914: RIP: Update queued
*Apr 29 09:31:42.914: RIP: Update sent via Ethernet0/0
R1#
*Apr 29 09:31:49.534: RIP: received v2 update from 192.168.12.2 on Ethernet0/0
*Apr 29 09:31:49.534: RIP: Update contains 1 routes
R1#
*Apr 29 09:32:10.301: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (192.168.12.1)
*Apr 29 09:32:10.301: RIP: Update contains 1 routes
*Apr 29 09:32:10.301: RIP: Update queued
*Apr 29 09:32:10.302: RIP: Update sent via Ethernet0/0
R1#u all
All possible debugging has been turned off
!! here we can see there no any updates of loopback only we have NIC port !!
--------------------------------------------------------------------------------------------------------------------------------------
Social Plugin