Configure RIPv2 As according topology

Task 1 :- Configure IP Address As same Given in diagram

Task 2 :- Configure Loopback  on R1,R2,R3

Task 3 :- Configure RIPv1 and Check Routing table

Task 4 :- check the connectivity between R1 to R3

-----------------------------------------------------------------------------------------------------------------------

 Task 1 :- Configure IP Address As same Given in diagram

R1 Configuration...

R1#
*Apr 26 09:12:37.692: %SYS-5-CONFIG_I: Configured from console by console
R1#
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#interface ethernet 0/0
R1(config-if)#ip add 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)# 
 


R2 Configuration...

R2#
*Apr 26 09:16:12.660: %SYS-5-CONFIG_I: Configured from console by console
R2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#interface ethernet 0/0
R2(config-if)#

R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#

R2(config)#interface serial 2/0
R2(config-if)#
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#



R3 Configuration...

*Apr 26 09:20:10.290: %SYS-5-CONFIG_I: Configured from console by console
R3#

R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#
R3(config)#interface serial 2/0
R3(config-if)#
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit


-------------------------------------------------------------------------------------------------------------------------

Task 2 :- Configure Loopback  on R1,R2,R3

R1 configuration...

R1(config)#
R1(config)#interface loopback 1
*Apr 26 09:23:57.402: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up1
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#

R2 configuration...




R2(config)#
R2(config)#interface loopback 1
*Apr 26 09:23:57.402: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up1
R2(config-if)#ip address 2.2.2.2  255.255.255.0
R2(config-if)#


R3 configuration...

R3(config)#
R3(config)#interface loopback 1
*Apr 26 09:23:57.402: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up1
R3(config-if)#ip address 3.3.3.3  255.255.255.0
R3(config-if)#


----------------------------------------------------------------------------------------------------------------------------


Task 3 :- Configure RIPv1 and Check Routing table

R1 configuration...

R1(config)#
R1(config)#router rip
R1(config-router)#net
R1(config-router)#network 192.168.12.0
R1(config-router)#network 1.1.1.0
R1(config-router)#version 2

R1(config-router)#exit
R1(config)#do show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     2.0.0.0/8 [120/1] via 192.168.12.2, 00:00:05, Ethernet0/0
R     3.0.0.0/8 [120/2] via 192.168.12.2, 00:00:05, Ethernet0/0
R     192.168.23.0/24 [120/1] via 192.168.12.2, 00:00:05, Ethernet0/0

R1(config)#
R1(config)#



R2 configuration...

R2(config)#
R2(config)#router rip
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0
R2(config-router)#network 2.2.2.0
R2(config-router)#
version 2
R2(config-router)#exit
R2(config)#do show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     1.0.0.0/8 [120/1] via 192.168.12.1, 00:00:25, Ethernet0/0
R     3.0.0.0/8 [120/1] via 192.168.23.3, 00:00:02, Serial2/0

R2(config)#




R3 configuration...

R3(config)#
R3(config)#route
R3(config)#router rip
R3(config-router)#network 192.168.23.0
R3(config-router)#network 3.3.3.0

R3(config-router)#version 2
R3(config-router)#exit 

R3(config)#
R3(config)#do show ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

R     1.0.0.0/8 [120/2] via 192.168.23.2, 00:00:21, Serial2/0
R     2.0.0.0/8 [120/1] via 192.168.23.2, 00:00:21, Serial2/0
R     192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:21, Serial2/0

R3(config)# 
  

!! 1.0.0.0/8 will show because by default version do auto summarization  !!
----------------------------------------------------------------------------------------------------------------------------

Task 4 :- check the connectivity between R1 to R3

R1#ping
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/12/14 ms
R1#
R1#


R3...

R3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 11/12/13 ms
R3# 


!! RIPv1 is by default enable on Routeing process let'see !!


----------------------------------------------------------------------------------------------------------------------------

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 26 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive any version
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0/0            2        2    
    Loopback1             2        2    
      
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    192.168.12.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.12.2         120      00:00:17
  Distance: (default is 120)

R1#
 



Same on R2 and R3 ,



----------------------------------------------------------------------------------------------------------------------------